5D3 HDMI Stops working

Amsterdem

New member
http://www.cinema5d.com/viewtopic.php?f=30&t=41266

Anyone has this problem or can duplicate it? Supposed when the 5D3 hdmi connection with a Smallhd DP4, is loose or disrupted.

Plugging it back in causes the HDMI to not work, camera wont turn on unless battery is removed.

Once battery is removed, photo mode works, video works however HDMI output is gone, no signal

Waited a few hours and camera is back to normal, hdmi output to monitor is ok. Fully functional
 
Problem:
Supposed when the 5D3 hdmi connection with a Smallhd DP4, is loose or disrupted.
Plugging it back in causes the HDMI to not work, camera wont turn on unless battery is removed.
Once battery is removed, photo mode works, video works however HDMI output is gone, no signal
Waited a few hours and camera is back to normal, hdmi output to monitor is ok. Fully functional

Contacted Canon CPS:

I'm a gold member, this is when my camera HDMI output stopped working, so I called CPS. They tried to troubleshoot over the phone unsuccessfully, suggesting the HDMI might have shorted and that I need to bring it into Irvine Canon for repair.
Luckily, camera came back to life and so did the HDMI output.

Today, I went to CPS canon, asked them politely to check out this issue with the Smallhd DP4, they decline any troubleshoot with third party accessories, but took my camera back to access the HDMI port on the 5D3 to verify if there was a short. They said it was in working order, and blames the SmallHD DP4 for possibly shorting the 5D3 and temporary shutting down the 5d3. Really defensive response from them, mind you I'm a gold cps member with a large amount of canon gear invested over the years and they cant seem to borrow one of their 5d3 bodies and investigate the issue. I also asked about the light leak issue, and they could not provide any info or recalls at the moment stating they haven't officially received the orders for repair nor are they ready to fix the issue. Canon FAIL.

**As for Smallhd, I contacted them and they responded on page 2** SmallHD FTW

For now, if your hdmi cable is loose or disconnected, MAKE sure you turn OFF the DP4 and 5D3, remove the both batteries from the monitor and camera, and replug everything back in before turning the monitor and 5d3 on. My only solution, i dont have time to test with my own camera.
 
Last edited:
Hmm. I shot recently with the 5d mk3 and the small hd dp6. On the last shot of the day, my monitor went out. Tested the cam at home, hdmi worked. I sent the monitor to small hd and they said a small wire inside was the issue. Not saying this is the same, but your thread definitely caught my eye...
 
Oh man, so happy to find this.

Was losing my mind after it happened to me last week. Covering a 3 week event in Italy, and at the end of a long day of shooting, I had the same problem at the most crucial moment of the day.

Been shooting exclusively with my XF300 ever since, even though I have a 7D with me also, was afraid it was the DP4. Just totally lost confidence with 5D3 for now. It's beautiful but cannot afford to lose another day's finale.

CK
 
Back
Top