Announcement

Collapse
No announcement yet.

Canon 1DX MK II with Sigma 50/1.4 ART. Anyone?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Canon 1DX MK II with Sigma 50/1.4 ART. Anyone?

    Does anyone of you guys tested that setup? I wonder how autofocus works in continous video mode? Fast? Slow? How it looks comparing to Canon's 50/1.2?

    #2
    I'd like to know this as well, for the 50mm as well as the other Art lenses.
    Jaime VallÚs
    AJV Media
    Video, Photography & Graphic Design: www.ajvmedia.com

    Comment


      #3
      Seriously? No one using Sigmas with 1DX MKII?

      Comment


        #4
        This doesn't help much, but the 18-35mm and 50mm were very fast and smooth with the 7D Mark II...I sold them by the time I was testing the 1DX Mark II, but I would guess the full-frame 50mm would work well with it too.

        Comment


          #5
          I have the 50 1.4 A and the 35 1.4 A.

          They both work in AF mode. They can be "loudish" when the motor steps the focus. Speed is average. Movie Servo AF is not supported—that is the AF speed setting.

          You need to switch off peripheral illumination correction, or you get strange looking artefacts.

          Image quality is good as expected.
          @andreemarkefors

          Comment


            #6
            Movie Servo AF is not supported in which camera?

            Comment


              #7
              So AF in video mode works only with Canon lenses?

              Comment


                #8
                Talking about the 1DxmkII here. General auto focus works with Sigma (and Canon obviously).

                But there is a servo function that allows you to control speed of AF, and that only works with compatible lenses. This won't work with Sigmas, and also not all Canons. But it isn't limited to STM lenses either (even if performance might be best here).

                The AF will be 'continuous' with Sigmas though, so they work OK.
                @andreemarkefors

                Comment


                  #9
                  Thx Andree for info!

                  Comment


                    #10
                    I have updated the firmware on my 20 and 50 F1.4, seems to work fine with Servo AF in video mode, the new firmware was made for 1DX2's compatability.

                    canon's 50L is slow as always, is too old technology!

                    Comment

                    Working...
                    X