Results 1 to 4 of 4
  1. Collapse Details
    C100 mk1 is the hole 10-32'' or 1/4? Thanks in advance
    #1
    Senior Member
    Join Date
    Mar 2011
    Posts
    532
    Default
    i bought this (1/4'' to 3/8'' adaptor). I try to screw it on the hole of the audio handle of the Canon C100. It doesnt work. I've heard that the hole needs a 10-32''. Any tips ? Thank you. Have a good day.

    s-l1600.jpg


    Reply With Quote
     

  2. Collapse Details
    #2
    Senior Member paulears's Avatar
    Join Date
    May 2009
    Location
    Lowestoft - UK
    Posts
    1,640
    Default
    The thread should be a " Whitworth thread (BSW). The thread on those adaptors looks a bit shallow and fine to be that? This looks more like it.
    s-l640.jpg


    Reply With Quote
     

  3. Collapse Details
    #3
    Senior Member
    Join Date
    Jan 2013
    Location
    Connecticut
    Posts
    306
    Default
    I used to own a C100MK1. If memory serves me correct, the thread hole on the handle was 1/4-20. On the bottom of the camera, the thread holes are 1/4-20 and 3/8-16. These are standard thread sizes found on most cameras sold here in the US.


    Reply With Quote
     

  4. Collapse Details
    #4
    Senior Member
    Join Date
    Mar 2011
    Posts
    532
    Default
    https://www.bhphotovideo.com/c/produ..._arm_with.html
    I have this arm that i want to put on the audio handle of the canon c100.

    Maybe i could buy this ?
    1) https://www.bhphotovideo.com/c/produ...geID/accessory
    2) https://www.ebay.ca/itm/SMALLRIG-3-8...QAAOSw3ChbPtOJ

    What do you think ?
    Thanks in advance,


    Reply With Quote
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •