Results 1 to 2 of 2
  1. Collapse Details
    C200 Sensor Dust
    #1
    Senior Member
    Join Date
    Sep 2009
    Posts
    149
    Default
    Is anyone else having issues with sensor dust on their C200's? I have had a number of cameras before and none of them have attracted sensor dust like the C200. It even came from the factory with a few big pieces of dust on the OLPF. I used an arctic butterfly to remove most of it but I have a few stubborn pieces that seem to be welded on there. Maybe its not dust or its behind the OLPF rather than on the front of the glass. Who knows but its super annoying and I'm not curageous enough to attempt more agressive liquid cleaning with swabs.
    Last edited by shorty15; 08-11-2018 at 05:38 PM.


    Reply With Quote
     

  2. Collapse Details
    #2
    Senior Member
    Join Date
    Feb 2009
    Location
    Long Island
    Posts
    4,495
    Default
    There are always a few unlucky ones (been there) that receive cameras with dust particles on the inside of the OLPF/IR filter glass.

    If you can't brush it off, that's probably the case unless it's a smudge from something that came from one of your lenses or accidentally fell in while lenses were being changed (doubt it if you're careful and quick).

    If I had not bought and used so many cameras in my life I would question user error, but by now I can confidently tell you that no matter which company it is and in what amazing clean room/facility the camera was assembled, it still happens.


    Reply With Quote
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •