Results 1 to 3 of 3
  1. Collapse Details
    Issues with Tokina 11-20mm and Metabones T Speed Booster Ultra
    #1
    Junior Member
    Join Date
    Nov 2008
    Location
    Texas
    Posts
    21
    Unhappy
    I just picked up a brand new Tokina 11-20mm f/2.8 and a Metabones Speed Booster Ultra for my Panasonic GH4. When zooming in the lens stops down to f/3.8 at the tele end opens back up to f/2.0 as I zoom out towards the wide end. I've also noticed I can only stop it down to f/16 and it's supposed to go to f/22.

    I tested the Tokina on my Canon 7D Mark II and it's constant f/2.8 throughout the zoom range. My Canon 70-200mm f/2.8 seems to work just fine and keeps a constant f/2.0 when used on the GH4+Speed Booster. I'm not sure what to do as I'm extremely disappointed that the Tokina is now f/2.0-f/3.8 instead of a constant f/2.0 when used with the Metabones.

    Any one have a similar issue or know a fix for this?


    Reply With Quote
     

  2. Collapse Details
    #2
    Senior Member soarprod's Avatar
    Join Date
    Jun 2004
    Location
    Costa Mesa /OC /California
    Posts
    1,742
    Default
    I don't have that lens but did you upgrade the metabones firmware?


    Reply With Quote
     

  3. Collapse Details
    #3
    Junior Member
    Join Date
    Nov 2008
    Location
    Texas
    Posts
    21
    Default
    Yes. Both the Metabones and the GH4 have the latest firmware updates.


    Reply With Quote
     

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •