Results 1 to 3 of 3
  1. Collapse Details
    Heads up, Red Giant Universe turns off multiprocessing
    #1
    Senior Member
    Join Date
    Jun 2009
    Location
    Pittsburgh, PA
    Posts
    319
    Default
    I didn't think they would release it this soon but I thought you might want a heads up. Most/All of the Universe plugins set the flag telling After Effects to turn off multiprocessing when previewing and rendering. They claim it is by design, see this beta feedback thread I opened:

    https://redgiant.zendesk.com/entries/34484650

    Of course that means if you have a 30 layer comp and decide to use one Universe Blur, your entire render will now only use one core when rendering and previewing.

    It's true a handful of native AE effects turn off multiprocessing, but it's a very small handful. From this feedback it appeared the few Universe effects that don't turn off multiprocessing should (for example the Universe version of Knoll Light Factory EZ doesn't turn it off). Sharing the GPU is a very tricky problem and it is very possible they don't have an answer for it. But at least for me it kind of kills the whole usefulness of the Universe plugins.

    Oddly enough their new Universe enabled version of Magic Bullet Looks doesn't have a problem with multiprocessing, which seems kind of odd.

    Maybe they will fix this, but I'm holding off spending anything on Universe until they do. I can't afford to use anything that kills multprocessing during rendering.
    Matt Sorrels


    Reply With Quote
     

  2. Collapse Details
    #2
    Senior Member Andrius Simutis's Avatar
    Join Date
    Dec 2010
    Location
    Seattle
    Posts
    1,133
    Default
    whoa. Thanks for the heads up.


    Reply With Quote
     

  3. Collapse Details
    #3
    Senior Member
    Join Date
    Jun 2009
    Location
    Pittsburgh, PA
    Posts
    319
    Default
    After a few rounds Red Giant has enabled multiprocessing on the Universe AE plugins (version 1.0.1). But if you installed the beta you might not see it, turns out Adobe caches the multiprocessing flag on plugins and won't reload them even when the plugin is new/different. It's definitely a bug in AE, but I have no hope it will be fixed.

    If you did install the beta, once you upgrade to Universe 1.0.1 you will need to reset your AE preferences in order to get the correct multiprocessing flags for the plugins. To do this, hold down ALT+CTRL+SHIFT when starting AE. It will prompt you if you want to reset your preferences. Yes, this is kind of painful. The Red Giant guys are talking with Adobe about it, so perhaps it will get fixed or another less painful way to reset will be found. You might want to screen shot your preferences before you do this so you can restore them. And of course turn multiprocessing back on.
    Matt Sorrels


    Reply With Quote
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •