Results 1 to 3 of 3
  1. Collapse Details
    New 5D II_firmware 2.1.2 and magic lantern
    #1
    Thumbs up
    Hi
    I have a new 5D mark II with firmware 2.1.2 (it came with the camera).

    Can i install magic lantern with this firmware (for what i read i beliave i can't)?
    If not, can i downgrade to an older firmware that works with magic lantern?

    I've been looking for people with this problem but i'm having dificulties in finding answers.
    Really want to get answers and would like to donate to the people developing the hack: they should go work to Canon!
    I've been on magic lantern site and others but continue on a blank state.

    If you have the answers or now where i can go to try solve my questions... please help me.

    Thank you very much.


    Reply With Quote
     

  2. Collapse Details
    #2
    Default
    1. Although they have stated that they can hack the Mark III to my knowledge no such hack has been released yet.

    2. You don't need to worry, when the hack is released you can just install it over whatever firmware you have currently on your camera regardless of the version.


    Reply With Quote
     

  3. Collapse Details
    #3
    Senior Member marvinhello's Avatar
    Join Date
    Jul 2011
    Location
    Leeds, UK
    Posts
    507
    Default
    Quote Originally Posted by dtjohns1 View Post
    1. Although they have stated that they can hack the Mark III to my knowledge no such hack has been released yet.

    2. You don't need to worry, when the hack is released you can just install it over whatever firmware you have currently on your camera regardless of the version.
    The OP is asking about 5D Mark II.

    You have to downgrade the firmware in order to get ML to work, and you have to donate to get the 5D2 beta version, information can be found in Magic Lantern Wikia page.


    Reply With Quote
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •