Results 1 to 8 of 8
  1. Collapse Details
    Running F3 off 15v DC power?
    #1
    Senior Member Grug's Avatar
    Join Date
    Apr 2007
    Location
    Melbourne, Australia
    Posts
    2,014
    Default
    ​Hi guys,


    I've got a bit of an urgent problem. We've rented an F3 for a shoot on Monday and it arrived this evening, but the rental house appears to have forgotten to include the 4-pin DC power cable (we have the charger, but not the 4-pin plug end).


    The Globalmediapro V-mount battery charger I have has 4-pin DC output, but it's 15v 4.0A and I don't know if that will blow up the camera or not.


    Does anyone know whether it's safe to run the F3 from a higher voltage charger like this one?


    Reply With Quote
     

  2. Collapse Details
    #2
    Senior Member MPB's Avatar
    Join Date
    May 2009
    Location
    nyc
    Posts
    554
    Default
    the manual indicates 11 - 17v, but i don't know what kind of amperage is acceptable.


    Reply With Quote
     

  3. Collapse Details
    #3
    Default
    Some of the brick type lithium batteries produce close to 15v when fully charged, so I'm sure it'll be fine. I think the camera normally pulls close to 2A but that shouldn't cause a problem?


    Reply With Quote
     

  4. Collapse Details
    #4
    Senior Member
    Join Date
    May 2004
    Location
    Teaneck, NJ
    Posts
    2,451
    Default
    That should be fine.

    Ned


    Reply With Quote
     

  5. Collapse Details
    #5
    Senior Member Grug's Avatar
    Join Date
    Apr 2007
    Location
    Melbourne, Australia
    Posts
    2,014
    Default
    Cheers fellas, I'll give it try.


    Reply With Quote
     

  6. Collapse Details
    #6
    Junior Member
    Join Date
    Jan 2012
    Location
    Ann Arbor, MI
    Posts
    17
    Default
    Should be cool, i occasionally use a 14V bescor and it works just fine.


    Reply With Quote
     

  7. Collapse Details
    #7
    Senior Member
    Join Date
    Sep 2010
    Location
    Amsterdam, the Netherlands
    Posts
    145
    Default
    I use V-lock battery's all the time and when fully charged they start with 16.4 volts.
    no problem whatsoever.
    happy shooting!


    Reply With Quote
     

  8. Collapse Details
    #8
    Senior Member Grug's Avatar
    Join Date
    Apr 2007
    Location
    Melbourne, Australia
    Posts
    2,014
    Default
    It runs fine off the V-mount charger. Crisis averted!


    Reply With Quote
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •