PDA

View Full Version : Codecs for output



Park Edwards
11-12-2008, 03:41 PM
I output most of my files to .mp4 using .h264 codec. I noticed it crushes my blacks wayyy too much. I tried to upload an original video file to vimeo but the d/l just keeps stalling. It's a 286mb file. Any suggestions?

bearing
11-12-2008, 10:38 PM
Some codecs allows you to change parameters which may affect how much the blacks are crushed, the one in the ffdshow package for example.

Osslund
11-13-2008, 01:56 AM
I did a comparison between MPEG2/H264/WMV9.

The MPEG2 is not that biteffective so I ended up with around 12/Mbps.
H264 is so much more effective but videolevels are wrong.
WMV9 is very effective but couldn't handle 24fps as good as MPEG2 or H264.

In the end I liked MPEG2 the most because all levels and framerate was spot on and the coding in the end had no artefacts.

All files where edited in native resolution and fps and output as 1280x720 24fps.

Park Edwards
11-13-2008, 10:18 AM
thanks man, very helpful.

Park Edwards
11-13-2008, 12:22 PM
Editman:

d/l this and see if you can get a good output to where the blacks aren't crushed...i tried the mpeg2 and no such luck.

http://vimeo.com/2225618

Osslund
11-13-2008, 02:30 PM
First. My workflow is:

Original file -> Import to Avid in 720 24p project -> Make QT reference -> Encode in TMPGenc

In TMPGenc you can select between video and RGB levels for the output file. Working in this manner I have the same blacks all throu the different steps.
I work with RGB levels from start to finish since it has the biggest spectra.
Videolevels are in the 16-235 and RGB 0-255 steps.

It's very easy to mixup the levels and with H264 the back level is mostly raised with washed out video as a result.

Park Edwards
11-13-2008, 02:36 PM
Ahh, I have PPro. I do however have TMPGenc. I wonder if Adobe can use that as an exporter. Or I could output to some loss-less codec and then use TMPGenc later.

I've come across the washed out look using .h264, but that hasn't been the result so far. I'll just have to keep playing around until I find something.

OPHERBA
11-13-2008, 08:04 PM
Car3o, do you have Cineform with your PPro?

Park Edwards
11-13-2008, 09:44 PM
no, is it any good?

OPHERBA
11-13-2008, 11:16 PM
Try their 15 days trail version.

1-Convert the D90 mjepeg file to the Cineform codec
2-Now you will have a more robust AVI file to play with (CC or use the non RT noise reduction).
3-Export your final project to Cinform AVI.
4-You can import the file to Xvid4psp (free nice conversion program) http://www.winnydows.com/page.php?2 and see if you get a better export solution(S)

BTW, thanks again for the "noise free" settings!

Johnnie

Park Edwards
11-13-2008, 11:16 PM
I think I've found a good solution. Oddly enough, it seems that the codec for the mjpeg had something to do with it? I dunno, but I changed my mjpeg codec to Main Concept and output using .h264 and oddly enough, it worked fine...the black weren't crushed or anything. So, that being said, I'm happy again. Thanks for those who helped.